Joomla integration in new VPS: Solving Porblems between Joomla Editors and Linux Centos VPS

Since transfer to this server I'm having problems with a text editor that doesnt' want to open properly anymore since we're on this server.
more interesting, it works from my computer only, and not from any other computer (we tried 6)
very strange issue, I've been on it all day thinking it's a script problem but I think it's server side:
problem appeared today, all was ok on shared
windows IE7 gives an error message that says that access is denied, error code:0, in file mambots/editors/fckeditor/editor/fckeditor.html
line39 which says:
37 function LoadScript( url )
38 {
39 document.write( '<\/scr' + 'ipt>' ) ;
40 }

plus other errors related to line 182
182 if ( FCKBrowserInfo.IsGecko )
183 {
184 function Window_OnResize()
185 {
186 if ( FCKBrowserInfo.IsOpera )
187 return ;............................................

on Apache raw error logs there are also loads of errors related to javascript for this fck editor

so I thought maybe you would know why this thing is not working anymore under the new server while it was working before... if you can know that then at least it's going to help me identify the problem more precisely

Posted On: 06 Aug 2008 09:13 AM
it appears that your vps does not have ion cube loader installed. this is an application that is necessary for various scripts, and it is something that is standard installed on our vps. if you would like us to install ion cube loader ( witch several of the error messages in the apache error log are indicating ) please let us know.

yes, please install ioncube loader

also I just noticed that chmod 755.644 was not yet run on folders.files... I could try to do that myself but sometimes when i do that myself I got errors in js.calendars, and now is not the time to bring more errors to this website... so it would be very kind of you if you could also do that for me please
and thanks a lot for your always kind help

Posted On: 06 Aug 2008 10:30 AM

We are talking about joomla editor? If you trying to edit any files using it - check first if that file have 777 permissions. Without it editor will get permissions error.

Posted On: 06 Aug 2008 10:34 AM
actually, if I remember well, with suphp every folder should have permission 755 isnt' it?
in think folder 755 was given for all domains already, but we reloaded this one from shared yesterday but chmod 755folders 644 files was not performed here
Stas S.     
Posted On: 06 Aug 2008 11:16 AM

On VPS suphp isn't installed.
php files parsing by php5_module. apache&php installed using easyapache.

Posted On: 06 Aug 2008 11:21 AM
suphp was a requirement for this server setup as per ticket TNA-560313
but you're right, hfw staff didnt confirm that it had been done...
shouldn't it be installed in order to avoid running scripts with 777 autorisations?

Posted On: 06 Aug 2008 11:49 AM

Rebuilding php with suphp support, please hold on.

Posted On: 06 Aug 2008 05:22 PM
the rebuild is now complete.

Posted On: 07 Aug 2008 08:32 AM
I'm coming back to the beginning of this ticket:
I've spent so many hours now trying to find out why my editor toolbar wouldnt' load now that we're on vps...
I've tried to look into the script and autorisations as much as I could but can't find why
problem must be coming from different settings of server or libraries or something
what information would you need from me so that you could identify the problem please... on my side I've used all my resources and failed... I just hope I'm right and that it's from server config and not from script as it's all been fine for months

Please accept my apologies. suphp support was compiled with php setup, but wasn't enabled.
I've enabled it for all accounts, could you check you editor now?

Posted On: 07 Aug 2008 09:10 AM

no, unfortunately it's still not working, but thanks for your intervention.
I don't know what to say... it's failing only since migration
but out of 8 computers we tried on, 1 always has success (mine, even after all cache cleared), 7 always fail (and we tried dozens of times)... so it's the strangest issueyou can see an exemple on:
user: homeandl pass: HaRVeyPCM123
You'd be a hero if you could tell me why this is happening now...Kindly

Posted On: 07 Aug 2008 09:45 AM

Could you do screenshot with error?
I've added 'test' word in Condition, Location and in Description. Saved succesfully without any problems.
I'm using firefox 3.0.1.

Posted On: 07 Aug 2008 10:06 AM

thanks for looking.
here most computers don't see the editor bar load, and we tried many settings both on browsers, java, on the scripts, permissions, paths... 0% success on 7 machines, 100% success on mine :(my laptop opens all perfectly on IE and FF, my desktop never)
error are also on content edit where same editor is used... so it's nothing to do with admin script of component.
error message reads:access denied in
but apache logs have many lines regarding javascript

I was wondering if maybe there were not some java handlers or libraries that are not installed on the server and maybe some computers have local console that take care of that, some don't... and then it doesn't load...
some things that are on shared and not on vps yet...

if not that then should be settings in script and I'll keep on looking

sorry, forgot the screenshot
and also, there are some error messages in IE related go Gecko...

Could you check with FF3?
On my laptop everything excellent, on your laptop too, so I don't think that issue is on server side.

Posted On: 07 Aug 2008 10:51 AM

I was afraid you'd say that...
well... my customer's downloaded the latest firefox version and it's not working on his machine after dozens of tests... I concurr...
that website was built under php 4 and we're php5 now, do you think that could be an explaination?

Posted On: 07 Aug 2008 11:18 AM

Building php4 for you, please hold on.

PHP 4 is built:

sh-3.00# /usr/local/php4/bin/php -v
PHP 4.4.8 (cli) (built: Aug 7 2008 11:29:32)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
with Zend Extension Manager v1.2.2, Copyright (c) 2003-2007, by Zend Technologies
with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies

Best Regards,
Posted On: 08 Aug 2008 04:05 AM
I swapped this website back to reseller and it still shows same errors... and these errors were not coming up last week when we were on shared of course...
please tell me what are the backups available for rh&l from reseller account

Posted On: 08 Aug 2008 04:06 AM
I swapped this website back to reseller and it still shows same errors... and these errors were not coming up last week when we were on shared of course...
please tell me what are the backups available for rh&l from reseller account
Thanks a lot
Posted On: 08 Aug 2008 05:14 AM

On shared server we have backups from Jun 17 and Aug 2
Best regards,
Posted On: 08 Aug 2008 06:23 AM

I don't know how that works but can u please make sure that Aug 2 backup stays a while please
Thanks a lot

No problems, I've copied full cpanel backup on your VPS into /root directory.

This website uses Cookies